Wojciech Węgrecki
Zad 1
R1
Current configuration : 1001 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.2 102
frame-relay map ip 192.168.1.3 103
frame-relay interface-dlci 102
frame-relay interface-dlci 103
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.2
ip route 192.168.1.0 255.255.255.0 192.168.1.3
ip route 192.168.20.0 255.255.255.0 192.168.1.2
ip route 192.168.30.0 255.255.255.0 192.168.1.3
!
!
line con 0
line vty 0 4
login
!
!
!
End
Wyniki komendy show frame-relay *
R1#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 56 Num Status msgs Rcvd 56
Num Update Status Rcvd 0 Num Status Timeouts 16
R1#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.2 dlci 102, static, CISCO, status defined, active
Serial0/3/0 (up): ip 192.168.1.3 dlci 103, static, CISCO, status defined, active
R1#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R2
Current configuration : 1020 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.20.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.3 203
frame-relay interface-dlci 201
frame-relay interface-dlci 203
clock rate 128000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.1.3
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.30.0 255.255.255.0 192.168.1.3
!
!
line con 0
line vty 0 4
login
!
End
Wyniki komendy show frame-relay *
R2#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 167 Num Status msgs Rcvd 167
Num Update Status Rcvd 0 Num Status Timeouts 16
R2#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.1 dlci 201, static, CISCO, status defined, active
Serial0/3/0 (up): ip 192.168.1.3 dlci 203, static, CISCO, status defined, active
R2#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DCE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R3
Current configuration : 1001 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.1 301
frame-relay map ip 192.168.1.2 302
frame-relay interface-dlci 301
frame-relay interface-dlci 302
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.2
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.20.0 255.255.255.0 192.168.1.2
!
!
line con 0
line vty 0 4
login
!
!
!
End
Wyniki komendy show frame-relay *
R3#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 214 Num Status msgs Rcvd 213
Num Update Status Rcvd 0 Num Status Timeouts 16
R3#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.1 dlci 301, static, CISCO, status defined, active
Serial0/3/0 (up): ip 192.168.1.2 dlci 302, static, CISCO, status defined, active
R3#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DTE)
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 302, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
Zad 2
R1
Current configuration : 1174 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.100.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
no ip address
encapsulation frame-relay
!
interface Serial0/3/0.1 point-to-point
ip address 192.168.1.5 255.255.255.252
frame-relay interface-dlci 102
clock rate 2000000
!
interface Serial0/3/0.2 point-to-point
ip address 192.168.1.9 255.255.255.252
frame-relay interface-dlci 103
clock rate 2000000
!
interface Serial0/3/0.3 point-to-point
ip address 192.168.1.13 255.255.255.252
frame-relay interface-dlci 104
clock rate 2000000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.1.6
ip route 192.168.20.0 255.255.255.0 192.168.1.10
ip route 192.168.30.0 255.255.255.0 192.168.1.14
!
!
line con 0
line vty 0 4
login
!
!
End
Wyniki komendy show frame-relay *
R1#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 55 Num Status msgs Rcvd 55
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/3/0.1 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/3/0.2 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/3/0.3 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
R1#sh frame-relay map
Serial0/3/0.1 (up): point-to-point dlci, dlci 102, broadcast, status defined, active
Serial0/3/0.2 (up): point-to-point dlci, dlci 103, broadcast, status defined, active
Serial0/3/0.3 (up): point-to-point dlci, dlci 104, broadcast, status defined, active
R1#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0.1
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0.2
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0.3
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R2
Current configuration : 761 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.6 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.5 201
clock rate 128000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.5
!
!
no cdp run
!
!
line con 0
line vty 0 4
login
!
!
!
End
Wyniki komendy show frame-relay *
R2#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 118 Num Status msgs Rcvd 117
Num Update Status Rcvd 0 Num Status Timeouts 16
R2#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.5 dlci 201, static, CISCO, status defined, active
R2#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DCE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R3
Current configuration : 794 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.20.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.10 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.9 301
frame-relay interface-dlci 301
clock rate 128000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.9
!
!
no cdp run
!
!
line con 0
line vty 0 4
login
!
!
!
End
Wyniki komendy show frame-relay *
R3#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 146 Num Status msgs Rcvd 145
Num Update Status Rcvd 0 Num Status Timeouts 16
R3#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.9 dlci 301, static, CISCO, status defined, active
R3#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DCE)
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R4
Current configuration : 796 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.14 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.13 401
frame-relay interface-dlci 401
clock rate 128000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.13
!
!
no cdp run
!
!
line con 0
line vty 0 4
login
!
!
End
Wyniki komendy show frame-relay *
R4#sh frame-relay lmi
LMI Statistics for interface Serial0/3/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 172 Num Status msgs Rcvd 171
Num Update Status Rcvd 0 Num Status Timeouts 16
R4#sh frame-relay map
Serial0/3/0 (up): ip 192.168.1.13 dlci 401, static, CISCO, status defined, active
R4#sh frame-relay pvc
PVC Statistics for interface Serial0/3/0 (Frame Relay DCE)
DLCI = 401, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/3/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
Melaniuk Michał
Zadanie 1
PLIKI KONFIGURACYJNE:
Router R1:
Building configuration...
Current configuration : 1001 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.2 102
frame-relay map ip 192.168.1.3 103
frame-relay interface-dlci 102
frame-relay interface-dlci 103
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.2
ip route 192.168.1.0 255.255.255.0 192.168.1.3
ip route 192.168.20.0 255.255.255.0 192.168.1.2
ip route 192.168.30.0 255.255.255.0 192.168.1.3
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
End
Router R2:
Building configuration...
Current configuration : 1020 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.3 203
frame-relay interface-dlci 201
frame-relay interface-dlci 203
clock rate 128000
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.1.3
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.30.0 255.255.255.0 192.168.1.3
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router R3:
Building configuration...
Current configuration : 1001 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.1 301
frame-relay map ip 192.168.1.2 302
frame-relay interface-dlci 301
frame-relay interface-dlci 302
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.2
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.20.0 255.255.255.0 192.168.1.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Wyniki komendy show frame-relay *
Router R1:
R1#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R1#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.2 dlci 102, static, CISCO, status defined, active
Serial0/2/0 (up): ip 192.168.1.3 dlci 103, static, CISCO, status defined, active
R1#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 111 Num Status msgs Rcvd 111
Num Update Status Rcvd 0 Num Status Timeouts 16
Router R2:
R2#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DCE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R2#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.1 dlci 201, static, CISCO, status defined, active
Serial0/2/0 (up): ip 192.168.1.3 dlci 203, static, CISCO, status defined, active
R2#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 122 Num Status msgs Rcvd 122
Num Update Status Rcvd 0 Num Status Timeouts 16
Router R3:
R3#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DTE)
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 302, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R3#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.1 dlci 301, static, CISCO, status defined, active
Serial0/2/0 (up): ip 192.168.1.2 dlci 302, static, CISCO, status defined, active
R3#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 136 Num Status msgs Rcvd 135
Num Update Status Rcvd 0 Num Status Timeouts 16
Zadanie 2:
PLIKI KONFIGURACYJNE
Router R1
Building configuration...
Current configuration : 1174 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.100.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
!
interface Serial0/2/0.1 point-to-point
ip address 192.168.1.5 255.255.255.252
frame-relay interface-dlci 102
clock rate 2000000
!
interface Serial0/2/0.2 point-to-point
ip address 192.168.1.9 255.255.255.252
frame-relay interface-dlci 103
clock rate 2000000
!
interface Serial0/2/0.3 point-to-point
ip address 192.168.1.13 255.255.255.252
frame-relay interface-dlci 104
clock rate 2000000
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.1.6
ip route 192.168.20.0 255.255.255.0 192.168.1.10
ip route 192.168.30.0 255.255.255.0 192.168.1.14
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router R2:
Building configuration...
Current configuration : 761 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.6 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.5 201
clock rate 128000
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.5
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router R3:
Building configuration...
Current configuration : 794 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.10 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.9 301
frame-relay interface-dlci 301
clock rate 128000
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.9
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router R4:
Building configuration...
Current configuration : 796 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.1.14 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.1.13 401
frame-relay interface-dlci 401
clock rate 128000
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.0.0 192.168.1.13
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Wyniki komendy show frame-relay *
Router R1:
R1#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0.1
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0.2
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0.3
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R1#sh frame-relay map
Serial0/2/0.1 (up): point-to-point dlci, dlci 102, broadcast, status defined, active
Serial0/2/0.2 (up): point-to-point dlci, dlci 103, broadcast, status defined, active
Serial0/2/0.3 (up): point-to-point dlci, dlci 104, broadcast, status defined, active
R1#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 76 Num Status msgs Rcvd 76
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/2/0.1 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/2/0.2 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
LMI Statistics for interface Serial0/2/0.3 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 0 Num Status msgs Rcvd 0
Num Update Status Rcvd 0 Num Status Timeouts 16
Router R2:
R2#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DCE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R2#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.5 dlci 201, static, CISCO, status defined, active
R2#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 128 Num Status msgs Rcvd 127
Num Update Status Rcvd 0 Num Status Timeouts 16
Router R3:
R3#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DCE)
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R3#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.9 dlci 301, static, CISCO, status defined, active
R3#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 151 Num Status msgs Rcvd 150
Num Update Status Rcvd 0 Num Status Timeouts 16
Router R4:
R4#sh frame-relay pvc
PVC Statistics for interface Serial0/2/0 (Frame Relay DCE)
DLCI = 401, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
R4#sh frame-relay map
Serial0/2/0 (up): ip 192.168.1.13 dlci 401, static, CISCO, status defined, active
R4#sh frame-relay lmi
LMI Statistics for interface Serial0/2/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 166 Num Status msgs Rcvd 165
Num Update Status Rcvd 0 Num Status Timeouts 16
Zad 3
Niestety podczas realizacji zadania nie zapisaliśmy zrzutów ekranu z plików konfiguracyjnych poszczególnych routerów jednak wynik w postaci osiągalności komputerów przedstawimy na screenach. Cel ten osiągnęliśmy wykonując następujące operacje, oczywiście już po przydzieleniu adresów IP wszystkim interfejsom oraz skonfigurowaniu routingu statycznego:
R1
R1(config)#interface serial 0/0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay interface 102
R1(config-if-dcli)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no sh
R2
R2(config)#interface serial 0/0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay interface 201
R2(config-if-dcli)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no sh
R3
R3(config)#frame-relay switching
R3(config-if)#interface serial0/0/1
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay intf-type dce
R3(config-if)#frame-relay route 102 interface serial0/0/0 201
R3(config-if)#no sh
R3(config-if)#interface serial0/0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay intf-type dce
R3(config-if)#frame-relay route 201 interface serial0/0/1 102
R3(config-if)#no sh
Należy zaznaczyć, że bardzo ważne było podłączenie kabli serialowych. Oba końce DCE musiały znaleźć się na R3, inaczej topologia nie chciała poprawnie działać.Efektem była osiągalność PC1 i PC2:
PC2 -> PC1
PC2 -> PC1