version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0/0/0.1 multipoint
description Link to R2, R4
ip address 10.1.110.1 255.255.255.0
ip ospf network point-to-multipoint
ip ospf hello-interval 10
frame-relay map ip 10.1.110.2 112 broadcast
frame-relay map ip 10.1.110.4 114 broadcast
!
interface Serial0/0/0.2 point-to-point
description Link to R3
ip address 10.1.113.1 255.255.255.0
frame-relay interface-dlci 113
!
interface Serial0/0/0.116 point-to-point
description Link to BBR2
ip address 10.1.116.1 255.255.255.0
frame-relay interface-dlci 116
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 10.1.110.0 0.0.0.255 area 24
network 10.1.113.0 0.0.0.255 area 3
network 10.1.116.0 0.0.0.255 area 0
neighbor 10.1.110.2 cost 10
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end