IEWB-RS Version 4.0 Solutions Guide Lab 5
1. WAN Technologies
Task 1.1
R2:
interface Serial0/0
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 162.1.0.2 255.255.255.0
frame-relay interface-dlci 203
R3:
interface Serial1/0
ip address 162.1.0.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 162.1.0.2 302 broadcast
frame-relay map ip 162.1.0.4 304 broadcast
frame-relay map ip 162.1.0.5 305 broadcast
no frame-relay inverse-arp
R4:
interface Serial0/0
ip address 162.1.0.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 162.1.0.2 403
frame-relay map ip 162.1.0.3 403 broadcast
frame-relay map ip 162.1.0.5 405 broadcast
no frame-relay inverse-arp
R5:
interface Serial0/0
ip address 162.1.0.5 255.255.255.0
encapsulation frame-relay
frame-relay map ip 162.1.0.2 504
frame-relay map ip 162.1.0.3 503 broadcast
frame-relay map ip 162.1.0.4 504 broadcast
no frame-relay inverse-arp
Task 1.1 Breakdown
The first step in configuring the about Frame Relay network should be to
determine what type of interface to use on R2. Note that the task states that to
not use any dynamic Frame Relay mappings on any of these circuits. , as well
as do not use any static Frame Relay mappings on R2. These leaves R2 with
the only option of using a point-to-point subinterface. Next, how to deal with
protocol resolution between the rest of the network must be determined.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 1
IEWB-RS Version 4.0 Solutions Guide Lab 5
Since Inverse-ARP cannot be used to resolve mappings between spokes of a
partial mesh it cannot be an option in this task. The task additionally states that
traffic from R5 destined for R2 should transit R4. Therefore R5 s layer 3
resolution statement for the 162.X.0.2 address should point to VC 504 via R4.
Since all other traffic should take the most direct path through the Frame Relay
network , R3 should resolve directly to R2, R4, and R5 through VCs 302, 304,
and 305 respectively, R4 should resolve to R2 and R3 through VC 403, and
through VC 405 to get to R5, and lastly R5 should resolve to R4 via 504 and R3
via 503.
Task 1.1 Verification
Rack1R3#show frame-relay map
Serial1/0 (up): ip 162.1.0.2 dlci 302(0x12E,0x48E0), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 162.1.0.4 dlci 304(0x130,0x4C00), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 162.1.0.5 dlci 305(0x131,0x4C10), static,
broadcast,
CISCO, status defined, active
Rack1R3#ping 162.1.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 162.1.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms
Rack1R3#ping 162.1.0.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 162.1.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms
Rack1R3#ping 162.1.0.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 162.1.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
Lastly, verify that packets from R5 traverse R4 on the way to R2:
Rack1R5#traceroute 162.1.0.2
Type escape sequence to abort.
Tracing the route to 162.1.0.2
1 162.1.0.4 32 msec 28 msec 28 msec
2 162.1.0.3 40 msec 40 msec 40 msec
3 162.1.0.2 56 msec * 52 msec
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 2
IEWB-RS Version 4.0 Solutions Guide Lab 5
Task 1.2
R1:
interface Serial0/0
ip address 162.1.13.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 162.1.13.3 113 broadcast
no frame-relay inverse-arp
R3:
interface Serial1/1
ip address 162.1.13.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 162.1.13.1 311 broadcast
no frame-relay inverse-arp
Task 1.2 Verification
Rack1R3#show frame-relay map | begin 1/1
Serial1/1 (up): ip 162.1.13.1 dlci 311(0x137,0x4C70), static,
broadcast,
CISCO, status defined, active
Rack1R3#ping 162.1.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 162.1.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms
Task 1.3
R6:
interface Serial0/0/0
encapsulation frame-relay
!
interface Serial0/0/0.1 multipoint
ip address 54.1.1.6 255.255.255.0
frame-relay interface-dlci 101
Task 1.3 Breakdown
This task will require that a multipoint subinterface be used. This is due to the
fact that if inverse-ARP is used on the main physical interface there would be
more dynamic mappings between R6 and BB1. This would mean that the output
of the show frame-relay map command would differ. If a point-to-point interface
was used the mapping would not be dynamic.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 3
IEWB-RS Version 4.0 Solutions Guide Lab 5
Task 1.3 Verification
Rack1R6#show frame-relay map
Serial0/0/0.1 (up): ip 54.1.1.254 dlci 101(0x65,0x1850), dynamic,
broadcast,, status defined, active
Rack1R6#ping 54.1.1.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 54.1.1.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms
Task 1.4
R4:
interface Serial0/1
encapsulation ppp
ppp reliable-link
R5:
interface Serial0/1
encapsulation ppp
clockrate 64000
ppp reliable-link
Task 1.4 Verification
Rack1R5#show interface s0/1 | include CONNECT
LAPB DCE, state CONNECT, modulo 8, k 7, N1 12048, N2 3
Standard
RFC 1663: PPP Reliable Transmission
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 4
IEWB-RS Version 4.0 Solutions Guide Lab 5
2. Bridging and Switching
Task 2.1
SW1:
vtp domain CCIE
vtp mode transparent
!
vlan 4,27,38,162
!
interface FastEthernet0/1
switchport access vlan 162
!
interface FastEthernet0/3
switchport access vlan 38
!
interface FastEthernet0/5
switchport access vlan 2005
!
interface FastEthernet0/15
switchport access vlan 38
SW2:
vtp domain CCIE
vtp mode transparent
!
vlan 4,8,88,27,162
!
interface FastEthernet0/2
switchport access vlan 27
!
interface FastEthernet0/4
switchport access vlan 4
!
interface FastEthernet0/6
switchport access vlan 162
!
interface FastEthernet0/24
switchport access vlan 162
SW3:
vtp domain CCIE
vtp mode transparent
!
vlan 3,4,55
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/5
switchport access vlan 55
!
interface FastEthernet0/24
switchport access vlan 4
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 5
IEWB-RS Version 4.0 Solutions Guide Lab 5
SW4:
vtp domain CCIE
vtp mode transparent
!
vlan 6
!
interface FastEthernet0/6
switchport access vlan 6
Task 2.1 Verification
Rack1SW1#show vtp status | include (Operating Mode|Name)
VTP Operating Mode : Transparent
VTP Domain Name : CCIE
Rack1SW1#show vlan brief | exclude (unsup|^1 |^ )
VLAN Name Status Ports
---- -------------------------------- -------- ------------
4 VLAN0004 active
27 VLAN0027 active
38 VLAN0038 active Fa0/3, Fa0/15
162 VLAN0162 active Fa0/1
2005 VLAN2005 active Fa0/5
Rack1SW2#show vtp status | include (Operating Mode|Name)
VTP Operating Mode : Transparent
VTP Domain Name : CCIE
Rack1SW2#show vlan brief | exclude (unsup|^1 |^ )
VLAN Name Status Ports
---- -------------------------------- -------- ------------
4 VLAN0004 active Fa0/4
8 VLAN0008 active
27 VLAN0027 active Fa0/2
88 VLAN0088 active
162 VLAN0162 active Fa0/6, Fa0/24
Rack1SW3#show vtp status | include (Operating Mode|Name)
VTP Operating Mode : Transparent
VTP Domain Name : CCIE
Rack1SW3#show vlan brief | exclude (unsup|^1 |^ )
VLAN Name Status Ports
---- -------------------------------- -------- ------------
3 VLAN0003 active Fa0/3
4 VLAN0004 active Fa0/24
55 VLAN0055 active Fa0/5
Rack1SW4#show vtp status | include (Operating Mode|Name)
VTP Operating Mode : Transparent
VTP Domain Name : CCIE
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 6
IEWB-RS Version 4.0 Solutions Guide Lab 5
Rack1SW4#show vlan brief | exclude (unsup|^1 |^ )
VLAN Name Status Ports
---- -------------------------------- -------- ------------
6 VLAN0006 active Fa0/6
Task 2.2
SW1:
interface Port-channel12
switchport trunk encapsulation isl
switchport mode trunk
!
interface Port-channel13
switchport trunk encapsulation isl
switchport mode trunk
!
interface Port-channel14
switchport trunk encapsulation isl
switchport mode trunk
!
interface range Fa0/13 - 14
switchport trunk encapsulation isl
switchport mode trunk
channel-group 12 mode on
no shutdown
!
interface range Fa0/16 - 17
switchport trunk encapsulation isl
switchport mode trunk
channel-group 13 mode on
no shutdown
!
interface range Fa0/19 - 20
switchport trunk encapsulation isl
switchport mode trunk
channel-group 14 mode on
no shutdown
SW2:
interface Port-channel12
switchport trunk encapsulation isl
switchport mode trunk
!
interface range Fa0/13 - 14
switchport trunk encapsulation isl
switchport mode trunk
channel-group 12 mode on
no shutdown
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 7
IEWB-RS Version 4.0 Solutions Guide Lab 5
SW3:
interface Port-channel13
switchport trunk encapsulation isl
switchport mode trunk
!
interface range Fa0/13 - 14
switchport trunk encapsulation isl
switchport mode trunk
channel-group 13 mode on
no shutdown
SW4:
interface Port-channel14
switchport trunk encapsulation isl
switchport mode trunk
!
interface range Fa0/13 - 14
switchport trunk encapsulation isl
switchport mode trunk
channel-group 14 mode on
no shutdown
Task 2.2 Breakdown
The first step in creating a layer 2 EtherChannel is to apply the channel-group
command to the interface. As previously discussed, the on mode of the channel
will disable the usage of both PAgP and LACP.
Next, configuration that should apply to both the channel interface and the
member interfaces should be placed on the port-channel interface. In the above
example the trunking configuration is shown on both the physical and logical
interfaces for clarity. Options configured on the port-channel interface will be
automatically inherited by the physical member interfaces.
The phase traffic sent over these trunk links should be tagged with a VLAN
header implies that ISL trunking must be used. By default only ISL tags all
VLANs sent over the trunk link with a VLAN header (remember dot1q uses the
native VLAN). However, in certain circumstances such as 802.1q tunneling, the
native VLAN can carry a VLAN header by issuing the global command vlan
dot1q tag native. This case will be covered in later labs.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
5 - 8
IEWB-RS Version 4.0 Solutions Guide Lab 5
Task 2.2 Verification
Verify that the port-channel is functional, for instance on SW2:
Rack1SW2#show etherchannel 12 port-channel
Port-channels in the group:
---------------------------
Port-channel: Po12
------------
Age of the Port-channel = 00d:00h:18m:19s
Logical slot/port = 2/12 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/13 On/FEC 0
0 00 Fa0/14 On/FEC 0
Time since last port bundled: 00d:00h:18m:14s Fa0/13
Verify the Etherchannel trunk encapsulation, for instance on SW2:
Rack1SW2#show interfaces port-channel 12 switchport
Name: Po12
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled