IEWB-RS Volume I Version 4.0 Solutions Guide Lab 3
1. Bridging and Switching
Task 1.1
R6:
interface GigabitEthernet0/0.16
encapsulation dot1Q 16
!
interface GigabitEthernet0/0.36
encapsulation dot1Q 36
SW2:
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 16,36
switchport mode trunk
Task 1.1 Breakdown
By default all VLANs are allowed to transit a trunk link. As previously mentioned,
VTP pruning can automatically remove unnecessary VLAN traffic from a trunk
interface. However, not all devices that support trunking also support pruning.
This is the case in the above configuration when enabling router-on-a-stick with
R6.
Since R6 does not support the automatic removal of unnecessary VLAN traffic,
unassigned VLANs must be manually removed from SW1 s Fa0/6 interface by
editing the allowed list. The allowed VLAN list, as the name implies, specifies
which VLANs are allowed to transit a trunk link. To edit the allowed VLAN list,
issue to switchport trunk allowed vlan interface level command.
Strategy Tip
Task 1.1 and 1.2 can not be verified until task 1.3 is completed. SW2 is a
VTP client so it will need to learn about the VLANs from the VTP server over
a trunk link. SW1 is the VTP server and the trunk between SW1 and SW2
isn t done until task 1.3.
This is a good example of why it is recommended to read over the lab prior
to starting. Issues like this can be caught before time is possibly wasted
trying to verify task 1.1 and 1.2 before task 1.3 has been completed.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
3 - 1
IEWB-RS Volume I Version 4.0 Solutions Guide Lab 3
Task 1.1 Verification
Task 1.3 is completed prior to verification of task 1.1 and 1.2.
Verify the trunking encapsulation and the allowed VLANs:
Rack1SW2#show interface trunk
Port Mode Encapsulation Status Native vlan
Fa0/6 on 802.1q trunking 1
Fa0/13 auto 802.1q trunking 1
Fa0/14 auto 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/6 16,36
Fa0/13 1-4094
Fa0/14 1-4094
Port Vlans allowed and active in management domain
Fa0/6 16,36
Fa0/13 1,3-4,16,29,36,44,52,57,63
Fa0/14 1,3-4,16,29,36,44,52,57,63
Port Vlans in spanning tree forwarding state and not pruned
Fa0/6 16,36
Fa0/13 1,3-4,16,29,36,44,52,57,63
Fa0/14 1,3-4,16,29,36,44,52,57,63
Task 1.2
R6:
bridge irb
!
interface GigabitEthernet0/0.16
bridge-group 1
!
interface GigabitEthernet0/0.36
bridge-group 1
!
interface BVI1
ip address 136.1.136.6 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
Task 1.2 Breakdown
By default Cisco routers will route IP and bridge all other protocols on all
interfaces. Additionally, a protocol can be either routed or bridged, but not both.
By using either the concurrent routing and bridging (CRB) or integrated routing
and bridging (IRB) features this limitation can be overcome.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
3 - 2
IEWB-RS Volume I Version 4.0 Solutions Guide Lab 3
With CRB, a protocol can be routed on one interface while being bridged on
another interface. When CRB is used, traffic in the routed domain cannot be
passed on to the bridge domain. With IRB, a protocol can be both routed and
bridged on the same interface. Therefore traffic from the routed domain can be
passed on to the bridge domain.
These features are useful when you want to extend the broadcast domain for one
protocol, while maintaining it for another. For example, IPX can be bridged
between two LAN segments, while IP is routed on those interfaces (CRB).
Additionally a bridge virtual interface (BVI) can be configured with an IPX
address so that other segments running IPX routing can communicate with the
IPX bridged network (IRB). CRB is considered a legacy feature since IRB
inherits all functionality of CRB, with the addition of the BVI.
In the above example two LAN segments running IP need to be bridged together.
The first step in bridging is to create a transparent bridge group. This is
accomplished by issuing the global configuration command bridge [num]
protocol ieee. The ieee option specifies that IEEE spanning-tree will be enabled
for the bridge group. To apply the bridge-group use the interface command
bridge-group [num], where num is the bridge group previously created.
Since ip routing is enabled by default the above configuration will only enable
transparent bridging for non-IP protocols. To enable the integrated routing and
bridging process, use the global configuration command bridge irb. Next,
choose which protocols you want to route and bridge for the bridge group. This
is accomplished by issuing the bridge [num] route [protocol]. In the above
case, IP is both routed and bridged for bridge group 1. Lastly, the BVI is
created by issuing the interface bvi [num], where num is the bridge group
number. All traffic that passes from the bridge domain to the routed
domain and vice versa must pass through the BVI. This is the interface
where logical configuration is placed, such as an IP address.
Copyright © 2007 Internetwork Expert www.InternetworkExpert.com
3 - 3
IEWB-RS Volume I Version 4.0 Solutions Guide Lab 3
Task 1.2 Verification
Task 1.3 is completed prior to verification of task 1.1 and 1.2.
Verify the IRB configuration on R6:
Rack1R6#show interface irb | begin GigabitEthernet0/0
GigabitEthernet0/0
Not bridging this sub-interface.
GigabitEthernet0/0.16
Routed protocols on GigabitEthernet0/0.16:
ip
Bridged protocols on GigabitEthernet0/0.16:
appletalk clns decnet ip